OCTAPLUSUK - Loss of Services in the Peterborough Area – Incident details

System Under Maintenance

Loss of Services in the Peterborough Area

Resolved
Under maintenance
Started 13 days agoLasted about 11 hours

Affected

CITYFIBRE

Under maintenance from 5:58 AM to 5:27 PM

Peterborough

Under maintenance from 5:58 AM to 5:27 PM

Updates
  • Resolved
    Resolved

    CityFibre is pleased to confirm that the issue affecting services in the Peterborough area was resolved at 14:59 on 17/06/2025. The resolution was achieved following the restoration of power by the DNO. Thank you for your patience

  • Identified
    Identified

    Incident Start Time: 23:34, 17/06/2025 Summary Update: The Major Incident Team continues to investigate a service-affecting incident impacting multiple live services in the Peterborough area. Preliminary investigations indicate a localised power issue in the vicinity of the affected site. Due to a flashover event, all on-site activity has been suspended in accordance with health and safety protocols. The local utility provider is required to carry out a full health and safety audit and the crew has to be replaced before any further work can proceed. In the interim, CityFibre has arranged for a generator to be deployed to the site, with an ETA of 15:00. Next Update At: 16:00, 17/06/2025

  • Investigating
    Investigating

    Cityfibre Team is currently investigating an incident affecting multiple live services in the Peterborough area. There are indications of localised power issues in the vicinity of the site. Cityfibre's NOC engineers have escalated the issue to the power company, who have acknowledged the request and are reviewing next steps for site attendance and investigation. Cityfibre's team has also explored their options with third-party contractors for a potential power workaround; however, this proposed solution was unfortunately not feasible. Next Update At: 10:00, 17/06/2025